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Q1. The physical components of a computer are called: 

a) Software

b) Hardware

c) Data

d) Program

Answer: b) Hardware

Q2. Which generation of computers used vacuum tubes? 

a) First

b) Second

c) Third

d) Fourth

Answer: a) First

Q3. ALU is a part of: 

a) Input Unit

b) Memory Unit

c) CPU

d) Output Unit

Answer: c) CPU

Q4. Which device is an example of an input device? 

a) Monitor

b) Keyboard

c) Printer

d) Speaker

Answer: b) Keyboard

Q5. Which of the following is volatile memory? 

a) ROM

b) Hard Disk

c) RAM

d) CD-ROM

Answer: c) RAM

Q6. Which memory is the fastest? 

a) Cache

b) Main Memory

c) Hard Disk

d) Flash Drive

Answer: a) Cache

Unit I: Computer Fundamentals (25 MCQs) 



Q7. Mainframe computers are used for: 

a) Small businesses 

b) Scientific research 

c) Large organizations 

d) Personal use 

Answer: c) Large organizations 

Q8. Translator that converts high-level language into machine code line by line is: 

a) Compiler 

b) Interpreter 

c) Assembler 

d) Linker 

Answer: b) Interpreter 

Q9. Which of these is system software? 

a) Antivirus 

b) Word Processor 

c) Compiler 

d) Spreadsheet 

Answer: c) Compiler 

Q10. Which is not an example of output device? 

a) Printer 

b) Plotter 

c) Scanner 

d) Monitor 

Answer: c) Scanner 

Q11. Which of the following is not a type of computer? 

a) Analog 

b) Digital 

c) Mechanical 

d) Hybrid 

Answer: c) Mechanical 

Q12. Registers are located in: 

a) CPU 

b) Hard Disk 

c) RAM 

d) Cache 

Answer: a) CPU 

Q13. WinZip is used for: 

a) Scanning 

b) Compressing files 

c) Formatting disks 

d) Encrypting data 

Answer: b) Compressing files 



Q14. Antivirus software is an example of: 

a) Utility software 

b) System software 

c) Application software 

d) Firmware 

Answer: a) Utility software 

Q15. Computer language directly understood by CPU is: 

a) Assembly 

b) High-level language 

c) Machine language 

d) Java 

Answer: c) Machine language 

Q16. In memory hierarchy, which is at the top (fastest)? 

a) Secondary 

b) Cache 

c) Primary 

d) Registers 

Answer: d) Registers 

Q17. Which computer is smallest in size? 

a) Mini 

b) Micro 

c) Mainframe 

d) Super 

Answer: b) Micro 

Q18. Which device is an output device? 

a) Mouse 

b) Joystick 

c) Monitor 

d) Keyboard 

Answer: c) Monitor 

Q19. Software that manages computer hardware is: 

a) Utility 

b) Application 

c) System Software 

d) Firmware 

Answer: c) System Software 

Q20. Compiler converts: 

a) Assembly to Machine 

b) High-level to Machine 

c) Machine to High-level 

d) Binary to Decimal 

Answer: b) High-level to Machine 



Q21. A device used to digitize documents is: 

a) Printer 

b) Scanner 

c) Plotter 

d) Monitor 

Answer: b) Scanner 

Q22. Which generation of computers used integrated circuits? 

a) First 

b) Second 

c) Third 

d) Fourth 

Answer: c) Third 

Q23. Which is not an application software? 

a) MS Word 

b) Excel 

c) Compiler 

d) PowerPoint 

Answer: c) Compiler 

Q24. Which memory is non-volatile? 

a) RAM 

b) Cache 

c) ROM 

d) Registers 

Answer: c) ROM 

Q25. Hybrid computer is a combination of: 

a) Analog + Digital 

b) Digital + Micro 

c) Analog + Mainframe 

d) None 

Answer: a) Analog + Digital 

 

Unit II: Word Processing (25 MCQs) 

Q1. Which tab in MS Word contains the Font group? 

a) Insert 

b) Home 

c) Layout 

d) View 

Answer: b) Home 

Q2. Shortcut to save a document in MS Word is: 

a) Ctrl + S 

b) Ctrl + O 



c) Ctrl + N 

d) Ctrl + P 

Answer: a) Ctrl + S 

Q3. Mail Merge feature is used for: 

a) Creating charts 

b) Sending bulk letters 

c) Spell check 

d) Drawing 

Answer: b) Sending bulk letters 

Q4. The default file extension of MS Word document is: 

a) .doc 

b) .docx 

c) .txt 

d) .xls 

Answer: b) .docx 

Q5. Track Changes is useful for: 

a) Formatting text 

b) Reviewing documents 

c) Printing documents 

d) Opening files 

Answer: b) Reviewing documents 

Q6. Which option is used to insert page numbers in MS Word? 

a) Header & Footer 

b) Insert → Page Number 

c) Layout → Margins 

d) References 

Answer: b) Insert → Page Number 

Q7. Which feature finds and replaces words in MS Word? 

a) Track Changes 

b) Spell Check 

c) Find & Replace 

d) Mail Merge 

Answer: c) Find & Replace 

Q8. WordArt is used for: 

a) Drawing shapes 

b) Artistic text 

c) Chart making 

d) Clipart 

Answer: b) Artistic text 

Q9. Macro in Word is: 

a) Animation 

b) Recording of tasks 

c) Equation editor 



d) Table format 

Answer: b) Recording of tasks 

Q10. Which option sets page orientation? 

a) References 

b) Page Layout → Orientation 

c) Insert 

d) Review 

Answer: b) Page Layout → Orientation 

Q11. To check spelling and grammar, press: 

a) F2 

b) F5 

c) F7 

d) F9 

Answer: c) F7 

Q12. Shortcut key for creating a new document is: 

a) Ctrl + N 

b) Ctrl + C 

c) Ctrl + D 

d) Ctrl + E 

Answer: a) Ctrl + N 

Q13. Which feature combines text with data source? 

a) Track Changes 

b) Mail Merge 

c) Find 

d) Format Painter 

Answer: b) Mail Merge 

Q14. The smallest font size in MS Word is: 

a) 6 

b) 8 

c) 10 

d) 12 

Answer: a) 6 

Q15. Which tab contains the Table option? 

a) Insert 

b) Design 

c) View 

d) Review 

Answer: a) Insert 

Q16. MS Word is an example of: 

a) Spreadsheet software 

b) Word processing software 

c) DBMS 



d) Presentation software 

Answer: b) Word processing software 

Q17. Header appears at: 

a) Top of page 

b) Bottom of page 

c) Both top and bottom 

d) Only once 

Answer: a) Top of page 

Q18. Footer appears at: 

a) Top of page 

b) Bottom of page 

c) Center of page 

d) Margin 

Answer: b) Bottom of page 

Q19. Format Painter is used for: 

a) Copying text 

b) Copying formatting 

c) Copying files 

d) Copying pictures 

Answer: b) Copying formatting 

Q20. To insert a hyperlink, we use: 

a) Ctrl + H 

b) Ctrl + K 

c) Ctrl + L 

d) Ctrl + P 

Answer: b) Ctrl + K 

Q21. Which menu helps in setting margins? 

a) Insert 

b) Layout 

c) Design 

d) Review 

Answer: b) Layout 

Q22. Shortcut to print document is: 

a) Ctrl + O 

b) Ctrl + P 

c) Ctrl + S 

d) Ctrl + N 

Answer: b) Ctrl + P 

Q23. Which view shows document in reduced size? 

a) Print Layout 

b) Outline 

c) Draft 



d) Zoom 

Answer: d) Zoom 

Q24. To insert symbol, go to: 

a) Insert → Symbol 

b) Layout → Symbols 

c) Design → Text 

d) Review → Insert 

Answer: a) Insert → Symbol 

Q25. MS Word was developed by: 

a) IBM 

b) Apple 

c) Microsoft 

d) Google 

Answer: c) Microsoft 

 

Unit III: Spreadsheet Software (25 MCQs) 

Q1. In Excel, rows are labeled as: 

a) A, B, C 

b) 1, 2, 3 

c) Both 

d) None 

Answer: b) 1, 2, 3 

Q2. Columns in Excel are labeled as: 

a) Numbers 

b) Letters 

c) Symbols 

d) Colors 

Answer: b) Letters 

Q3. Default file extension of Excel 2016 is: 

a) .xls 

b) .xlsx 

c) .docx 

d) .txt 

Answer: b) .xlsx 

Q4. A cell is identified by: 

a) Row number only 

b) Column letter only 

c) Column + Row 

d) File name 

Answer: c) Column + Row 



Q5. Which function adds values? 

a) SUM() 

b) AVERAGE() 

c) COUNT() 

d) IF() 

Answer: a) SUM() 

Q6. Formula in Excel starts with: 

a) + 

b) = 

c) # 

d) $ 

Answer: b) = 

Q7. Conditional Formatting is used to: 

a) Filter data 

b) Highlight cells 

c) Change formulas 

d) Add comments 

Answer: b) Highlight cells 

Q8. Which chart shows data as slices? 

a) Bar 

b) Line 

c) Pie 

d) Column 

Answer: c) Pie 

Q9. Shortcut to create a new workbook is: 

a) Ctrl + N 

b) Ctrl + S 

c) Ctrl + O 

d) Ctrl + P 

Answer: a) Ctrl + N 

Q10. Data Validation restricts: 

a) File size 

b) User input 

c) Fonts 

d) Charts 

Answer: b) User input 

Q11. Function to calculate average is: 

a) ADD() 

b) AVERAGE() 

c) MEAN() 

d) TOTAL() 

Answer: b) AVERAGE() 



Q12. To insert a row, use: 

a) Right click → Insert 

b) Ctrl + C 

c) Ctrl + V 

d) Delete 

Answer: a) Right click → Insert 

Q13. Which symbol locks cell reference? 

a) & 

b) $ 

c) # 

d) % 

Answer: b) $ 

Q14. Filter option is found under: 

a) Data tab 

b) Home tab 

c) Review tab 

d) View tab 

Answer: a) Data tab 

Q15. COUNT() function is used to: 

a) Add cells 

b) Count numbers 

c) Count text 

d) None 

Answer: b) Count numbers 

Q16. Excel is an example of: 

a) Word processor 

b) Spreadsheet 

c) DBMS 

d) Presentation software 

Answer: b) Spreadsheet 

Q17. Autofill is used to: 

a) Fill formulas 

b) Fill series 

c) Both 

d) None 

Answer: c) Both 

Q18. Shortcut to save workbook is: 

a) Ctrl + S 

b) Ctrl + P 

c) Ctrl + O 

d) Ctrl + Z 

Answer: a) Ctrl + S 



Q19. In Excel, cell reference A$1 means: 

a) Row fixed 

b) Column fixed 

c) Both fixed 

d) None 

Answer: a) Row fixed 

Q20. Financial function to calculate interest is: 

a) PMT() 

b) SUM() 

c) COUNT() 

d) IF() 

Answer: a) PMT() 

Q21. Shortcut to undo is: 

a) Ctrl + Y 

b) Ctrl + U 

c) Ctrl + Z 

d) Ctrl + R 

Answer: c) Ctrl + Z 

Q22. A worksheet is a collection of: 

a) Charts 

b) Tables 

c) Cells 

d) Workbooks 

Answer: c) Cells 

Q23. MAX() function is used to: 

a) Minimum value 

b) Maximum value 

c) Average value 

d) Median 

Answer: b) Maximum value 

Q24. Which date function returns current date? 

a) NOW() 

b) DATE() 

c) TODAY() 

d) TIME() 

Answer: c) TODAY() 

Q25. To print worksheet, use shortcut: 

a) Ctrl + N 

b) Ctrl + P 

c) Ctrl + O 

d) Ctrl + F 

Answer: b) Ctrl + P 

 



Unit IV: Database + Presentation Software (25 MCQs) 

Q1. In DBMS, a table is also called: 

a) Record 

b) Relation 

c) Field 

d) Query 

Answer: b) Relation 

Q2. Each row in a table is known as: 

a) Field 

b) Record 

c) Column 

d) Attribute 

Answer: b) Record 

Q3. Each column in a table is called: 

a) Record 

b) Tuple 

c) Field 

d) Key 

Answer: c) Field 

Q4. Primary Key is: 

a) Duplicate key 

b) Unique identifier 

c) Foreign key 

d) None 

Answer: b) Unique identifier 

Q5. Which SQL query is used to retrieve data? 

a) SELECT 

b) UPDATE 

c) DELETE 

d) INSERT 

Answer: a) SELECT 

Q6. In MS Access, forms are mainly used for: 

a) Data entry 

b) Data storage 

c) Data deletion 

d) Data backup 

Answer: a) Data entry 

Q7. Reports in DBMS are used to: 

a) Print data in formatted way 

b) Delete data 

c) Insert data 



d) Encrypt data 

Answer: a) Print data in formatted way 

Q8. Which is the default extension of PowerPoint 2016? 

a) .ppt 

b) .pptx 

c) .pps 

d) .docx 

Answer: b) .pptx 

Q9. Shortcut key to start slideshow from the beginning is: 

a) F2 

b) F5 

c) F7 

d) F9 

Answer: b) F5 

Q10. Master Slide in PowerPoint is used to: 

a) Add animations 

b) Maintain design consistency 

c) Insert sound 

d) Insert tables 

Answer: b) Maintain design consistency 

Q11. In DBMS, a query is used to: 

a) Enter data 

b) Retrieve/manipulate data 

c) Delete database 

d) Create reports 

Answer: b) Retrieve/manipulate data 

Q12. Foreign Key in DBMS is used to: 

a) Ensure uniqueness 

b) Link two tables 

c) Delete duplicates 

d) Create indexes 

Answer: b) Link two tables 

Q13. In PowerPoint, which view is used to see all slides at once? 

a) Normal View 

b) Outline View 

c) Slide Sorter View 

d) Reading View 

Answer: c) Slide Sorter View 

Q14. DBMS stands for: 

a) Database Managed System 

b) Database Management System 

c) Data Basic Managed Software 



d) Digital Base Managed System 

Answer: b) Database Management System 

Q15. Which is NOT a type of database model? 

a) Hierarchical 

b) Network 

c) Relational 

d) Linear 

Answer: d) Linear 

Q16. In PowerPoint, transitions are applied to: 

a) Text only 

b) Slide changes 

c) Images only 

d) Tables only 

Answer: b) Slide changes 

Q17. A form in DBMS is mainly used for: 

a) Data entry and editing 

b) Printing reports 

c) File compression 

d) Data backup 

Answer: a) Data entry and editing 

Q18. Which button is used for next slide during presentation? 

a) Spacebar 

b) Enter 

c) Right arrow 

d) All of these 

Answer: d) All of these 

Q19. Which key is used to end a slideshow in PowerPoint? 

a) Esc 

b) F1 

c) F4 

d) Tab 

Answer: a) Esc 

Q20. Which type of database stores data in rows and columns? 

a) Hierarchical 

b) Network 

c) Relational 

d) Object-oriented 

Answer: c) Relational 

Q21. Which option in PowerPoint is used to apply the same design to all slides? 

a) Slide Sorter 

b) Slide Master 

c) Animation Pane 



d) Design Ideas 

Answer: b) Slide Master 

Q22. In DBMS, a set of related records is called: 

a) File 

b) Field 

c) Tuple 

d) Key 

Answer: a) File 

Q23. Which feature in PowerPoint allows inserting clickable links? 

a) Hyperlink 

b) Action Button 

c) Bookmark 

d) Footer 

Answer: a) Hyperlink 

Q24. Which SQL command is used to remove a table? 

a) DELETE 

b) DROP 

c) REMOVE 

d) CLEAR 

Answer: b) DROP 

Q25. PowerPoint was developed by: 

a) Apple 

b) Google 

c) Microsoft 

d) IBM 

Answer: c) Microsoft 

 


